Go to page:

Search:   Help

Navigation

Groups

LyX documentation

Edit

Shared groups

Links

LyX /

Dependecies

Categories: LyX dependecies
<< | Page list | >>

Package dependecies

The aim of this page is to list required dependecies and problems for packagers of LyX.

Qt:

LyX 2.1.x series need Qt >= 4.5, tested with 4.8. Qt 5.x support is still experimental.

LyX 2.0.x series need Qt >= 4.2, widely tested with 4.6/7/8. Be prepared that although is LyX compilable with older Qt's it also unstable with them.

LyX 1.6.x series need Qt >= 4.2, 4.5 is optimal (all features enabled).

LyX 1.5.x series need Qt >= 4.1

Ghostscript:

Avoid Ghostscript 8.70.

dvipng

For better working of instant preview dvipng package should be installed.

LaTeX world

Some nonstandard packages needed for proper rendering of manuals: - xypic (texlive-pictures), mhchem (texlive-science) package needs to be found for manuals to work

Categories

Category: LyX dependecies

Edit - History - Print - Recent Changes - All Recent Changes - Search
Page last modified on 2014-02-09 20:31 CET