Go to page:

Search:   Help



LyX documentation


Shared groups


Mac /


Categories: Mac
<< | Page list | >>

LyX/Mac: About LyX-1.3.x on Mac OS X

NOTE: This document is based on legacy versions of LyX/Mac, namely 1.3.5 to 1.3.7; you might instead be interested in the page devoted to the more recent 1.4.x series.

This is a HOWTO for LyX/Mac, a fully-featured implementation of LyX on the Mac OSX native graphics display, with the familiar Aqua look & feel and anti-aliased text. LyX/Mac does not require X11. LyX/Mac was runner-up in the Qt/Mac Application Developer Contest.

New in LyX/Mac-1.3.7

  • The application bundle now includes Spotlight support for Mac OS X 10.4 and higher so that users can search the contents of their .lyx files with Spotlight.1
  • Creation of a new default templates folder in ~/Library/Application Support/LyX/templates/default. These are the template files supplied with LyX, and you can now navigate to them easily from the File -> New from Template... dialog. (Please note that all templates in this folder will be overwritten with each new release of LyX/Mac.)
  • LyX 1.3.7 is able to read all LyX files up to file format 245, the format that we anticipate will be used by the forthcoming LyX 1.4.0.
  • Bugfixes.

All current 1.3.x users are encouraged to upgrade to this version, which we anticipate to be the last release in the 1.3.x series. The new installer can now be downloaded from here: ftp://ftp.lyx.org/pub/lyx/bin/1.5.1/.


LyX/Mac is available as a self-installing binary based on LyX 1.3.7 and the GPL Qt/Mac library. The prerequisites are Mac OS 10.2 or later and teTeX. If you prefer to build LyX/Mac, instructions are included in the LyX source.

Note: All users should run the LyX Installer.command included with the LyX/Mac-1.3.7 distribution. (On multi-user systems, the script needs to be run once in each account.) The script will clean up old versions of preferences files and remove old fonts, which are no longer needed for LyX/Mac 1.3.4 and greater. It also moves your LyX user's directory to ~/Library/Application Support/LyX, where it is more easily accessed should you need to add or modify .bind files or templates, for example. (See Known Issues below for a potential pitfall here.


You need a TeX installation. There are three standard options for this:

  1. Use Gerben Wierda's convenient i-Installer. Clear and somewhat detailed instructions for what to install and how to install it can be found here. Simpler, less detailed instructions can be found here.
  2. Use the fink package management system to install tetex, ghostscript, and imagemagick.
  3. Use the Darwin ports package management system.

To use other implementations of teTeX which do not install the binaries in /usr/local/teTeX/bin/powerpc-apple-darwin-current, /sw/bin, /opt/local/teTeX/bin, or /usr/local/bin, either link the teTeX binaries to one of those directories, or add the PATH of your teTeX binaries to the PATH prefix field in LyX -> Preferences -> Paths.

Using LyX/Mac

Start LyX by double-clicking the icon. For those familiar with other versions of LyX, the Mac key functions as the CONTROL key for LyX key-mapping, and the Mac OPTION (ALT) key functions as both a META key and a COMPOSE key. For batch commands or debugging, you can start LyX from the command line with the case-sensitive /Applications/LyX.app/Contents/MacOS/lyx — modify as needed if you install LyX somewhere other than the Applications folder.

Drag files to the open LyX window to open them. To enable double-clicking LyX files in the Finder, set LyX as the default application in Finder -> File -> Get Info -> Open With.

Mac-like keyboard shortcuts for commands and cursor movements (like "OPT-LEFT" to move left one word) are provided as the default for new installations. (Users upgrading from earlier versions of LyX/Mac can specify mac.bind as their bind file in LyX -> Preferencs -> Look and Feel -> User Interface. (Simply type "mac.bind" in that field.) A ready-to-print list of the mapped shortcuts can be found here.

To change the GUI language, you'll need to modify your ~/.MacOSX/environment.plist file. For details, see the environment.plist page.


LyX/Mac uses the system default viewers, and should require no configuration for PDF and HTML. If you have MacDviX or MacGhostView installed, LyX will use them to preview DVI and Postscript. Another good previewer for .dvi, .ps, and .pdf files is TeXShop, which is also an excellent stand-alone TeX editor. Alternatively, you might want to use PDFView which is optimized for LaTeX and features, for example, automatic reloading of the viewed PDF every time the file is saved, that is, if you View --> Update your file in LyX, PDFView will automatically display the changes.
To specify a non-default GUI viewer use open -a app-name or open -a 'Application Name' in Preferences -> Outputs -> File formats -> filetype -> Viewer.
  • Spellcheckers compatible with LyX/Mac include aspell, ispell, and hspell; these can be selected from the drop-down list in LyX -> Preferences -> Language settings -> Spellchecker. (Installation Instructions)
  • To use cocoAspell, make sure you add at least one dictionary from the cocoAspell preference pane in System Preferences after installation. Note, however, that many users have reported problems with cocoAspell. If it doesn't work for you, try installing aspell directly.
Bibtex tools
Bibtex tools compatible with LyX/Mac include BibDesk, JabRef, tkbibtex (used with Tcl/Tk Aqua) or its aquafied counterpart, AquaTkbibtex, respectively, and Endnote (used with scripts that convert Endnote citations to LaTeX citations).
To define a path that will allow LyX to find your .bib files automatically, you may want to modify your ~/MacOSX/environment.plist file. For details, see the environment.plist page.
To print envelopes, install envelope in /usr/local/bin and make it executable. While you're writing a letter in LyX, do File -> Export -> Custom -> ASCII and give envelope as the command; it will parse the address from the letter and print an envelope, including the USPS barcode.

Beyond basics

To enable LyX menu shortcuts such as

OPTION-SHIFT-f pbuffer-print
OPTION-SHIFT-i s ssuperscript
OPTION-SHIFT-l playout-paragraph
OPTION-SHIFT-i h lmath-panel
OPTION-SHIFT-i ccitation-insert
OPTION-SHIFT-e x lprimary-selection-paste
OPTION-SHIFT-e sspellchecker
OPTION-SHIFT-e t atabular-feature append-row

Here is a ready-to-print list of the mapped shortcuts. (On some keyboards, the OPTION key may be labeled ALT.)

Note: aqua.bind is fully compatible with the default mac.bind file, and both can be used simultaneously. Just create a new file, my_bindings.bind, e.g., that consists of the following two lines:
     \bind_file aqua.bind
     \bind_file mac.bind
Place my_bindings.bind in ~/Library/Application Support/LyX/bind and enter my_bindings.bind as your Bind file in LyX -> Preferences -> Look and Feel -> User Interface.

Converting from TeX to LyX. LyX-1.3.6 uses reLyX to convert from TeX format to LyX format. A more advanced successor to reLyX is tex2lyx, which, though still under development, is nonetheless quite useful. Details about tex2lyx and a download link for the Mac version can be found at LatexToLyx.

For on-screen preview of math with latex-preview (as in the screenshot), make sure you have ghostscript installed and check Instant preview under Preferences -> Look & feel -> Graphics.

Interaction with X11. Xfig or X-windows previewers like xdvi or gv can be used with LyX/Mac if you modify your ~/MacOSX/environment.plist file. For details, see the environment.plist page. Alternatively, you can change the viewer for postscript or dvi with export DISPLAY=:0.0 && gv or export DISPLAY=:0.0 && xdvi. Note that X11 must be running first for either of these to work.

Reverse DVI search, so the cursor in LyX automatically jumps to the point where you OPTION-click (ALT-click) in the previewed DVI file, can be enabled with recent versions of teTeX and MacDviX or xdvi:

  • Change Preferences -> Converters -> Latex -> DVI -> Converter to latex --src $$i or include \usepackage[active]{srcltx} in the preamble of your LyX files.
  • For MacDviX, add at the end of /Applications/MacDviX_Folder/calleditor.script:
   /Applications/LyX.app/Contents/MacOS/lyxeditor "$2" $1
   exit 1
Modify as needed if you install LyX somewhere other than the Applications folder.
  • For xdvi, change Preferences -> Outputs -> File formats -> DVI -> Viewer to
   xdvi -editor 'lyxeditor %f %l'

XeTeX. XeTeX is "a typesetting system based on a merger of Donald Knuth's TeX system with Unicode and Mac OS X font technologies." In other words, it will let you use any of your standard Mac OS X fonts with TeX/LaTeX. To install XeTeX and get it to work with LyX/Mac, go here?.

Known issues

  1. Apparently some other software used in conjunction with LyX assumes that the LyXServer (which LyX uses to communicate with these programs) is located in the old LyX user's directory at ~/.lyx. If you experience troubles communicating with such software, you might try the following: (1) change the LyXServer path in LyX -> Preferences -> Paths back to ~/.lyx; (2) recreate the ~/.lyx directory by entering in a terminal session, "mkdir ~/.lyx"; and (3) restart LyX.
    • A modified version of Mark Reid's SendToLyX.scpt to allow BibDesk to send bibliographical citations to LyX can be found here. To use it, download the file to your disk, and move it to ~/Library/Application Support/BibDesk/Scripts. For more information on this script, see Mark's page here. Note: This page is currently down (checked 2012-11-10).
  2. Due to limitations in the Qt/Mac library, interface languages other than English modify the organization of the toolbar menus and it may not be possible to directly enter some special characters into the document preamble (you can copy them to the preamble).
  3. If math fonts do not show up on the screen properly, it may be because you have the CMdfont files installed (as suggested by MacDviX). Try disabling the following fonts: AMS.dfont, CM_2.dfont, CM_4.dfont, LaTeX.dfont, CM_1.dfont, CM_3.dfont, Euler.dfont, WNCY.dfont. (You will then have to reconfigure -- Edit -> Reconfigure -- and restart LyX.)
  4. It looks like the installer puts the following two lines in ~/Library/Application Support/LyX:
    \format "pdf" "pdf" "PDF (pdflatex)" ""
    \format "pdf2" "pdf" "PDF (ps to pdf)" ""

These redefine the pdf output formats in a wrong way and should be deleted.

Please report any other bugs to the appropriate Lyx mailing list.

The information on this page is believed to be accurate, has been used successfully on many systems and sites, and has benefited from the comments and suggestions of many users. Due to the variations in individual systems, this information and the various files and code available on this page are conveyed as is with no warranty of any kind.

1 (Information on including the Spotlight importer for versions of LyX/Mac prior to 1.3.7 can be found at the Spotlight page.)


Edit - History - Print - Recent Changes - All Recent Changes - Search
Page last modified on 2012-11-10 13:36 CET