Go to page:

Search:   Help

Navigation

Groups

LyX documentation

Edit

Shared groups

Links

LyX 1.3.7/1.4.1 for Windows - Installation Instructions

Categories: Windows, Installation
<< | Page list | >>

This page explains how to setup a complete LyX environment using the official installer for LyX 1.3.7/1.4.1.

The official releases of LyX 1.4.x and and the unofficial LyXWinInstaller for LyX 1.3.7/LyX 1.4.x setup everything automatically. You no longer need to follow the steps on this page.


Quick Start

This quickstart guide should be enough to get most people going. It's basically a summary of the detailed explanation below it. Cheers, Frode Egeland

This should be enough to get most people going:

Files needed

Steps

  1. Install each of the programs above.
  2. Install LyX last, so that LyX can find the other programs during its configuration.
  3. Run LyX!

You can preview and print your document by pressing Ctrl-D. If you have a PDF or Postscript viewer installed you can use it to view your document by calling it from the Tools menu.

If you are having problems or are less familiar with setting up programs you may find the following more detailed instructions helpful.


Detailed Setup Instructions

Installation

Install the programs found below in the order shown.

  1. Install MiKTeX
    This is the core program used by Lyx to output nice documents. After installing it, make sure that MiKTeX is able to install missing packages on-the-fly. To do this, go to Start→Programs→MiKTeX→MiKTeX Options →General→Package installation→Ask me first.
    Note: You should be able to use other LaTeX packages instead of MikTeX. One example is TeXLive, a CD-based version.
  2. Install Ghostscript.
    This is used to create Postscript documents, as well as for viewing .ps and .eps files inside LyX.
  3. Install ImageMagick (choose the file "ImageMagick-6.x.x-Q16-windows-dll.exe").
    ImageMagick is used to convert images into formats that LyX can understand.
  4. Optionally, install GSview, which lets you view Postscript files. This is recommended.
  5. Optionally, install a PDF viewer, if you do not already have one.
    This is also recommended. Adobe Reader is the most common. Alternates include the more compact Foxit reader and GSview, which shows PDF files in addition to Postscript.
  6. Download these math fonts math and install them in windows fonts folder.
    To install the fonts use Start→Settings→Control Panel→Fonts and then File→Install New Font. These fonts are used to display symbols in the LyX math editor.
  7. Finally, install LyX 1.4.1 for Windows.
    Installing it last ensures that it can find the programs listed above. If you install or update one of those programs later, go to Reconfigure in the Tools menu to make LyX look for it.

The first run

Start Lyx from the Start Menu or Desktop shortcut that was just created.

  • LyX should configure itself and create a LyX folder in C:\Documents and Settings\username\Application Data holding each users preferences.
  • MiKTeX will ask you if it may install some LaTeX-packages while LyX configures -- you should allow this.

To check if the setup worked, restart LyX, create a new document, type 'hello' and press Ctrl-d. Now a program called 'Yap' should appear with a preview of your document.

With LyX running you can now adjust some preferences, if you like. They are all in Preferences in the Tools menu. For example:

  • Change the fonts shown on the screen under Look and Feel->Fonts.
  • Change the screen color under Look and Feel->Colors.
  • Set your default paper size at Outputs->LaTeX.
  • Set your working directory, etc. under Paths.

Be careful with the other settings until you understand what each does! You DO NOT need to adjust any converters.


Turning on spellchecking

Unfortunately, the spellchecker is not enabled by the default. To enable spell checking, you need to install Aspell and the dictionaries you want to use.


Installation problems?

First, try the Reconfigure option again (Tools→Reconfigure).

If LyX can't find all additional programs like Adobe Reader and GSview after configuration do the following:

  1. Identify the programs which can't be found. If you don't know which program is missing, you can start LyX from a command prompt with the command lyx -dbg 3 and reconfigure LyX again (Tools→Reconfigure).
  2. Look in your Program Files folder to see where the missing files are.
  3. Add the paths of the missing files to Tools->Preferences->Paths->PATH Prefix

Go to the Bugs? page or ask on the mailing list for more help.


Windows Installation

Edit - History - Print - Recent Changes - All Recent Changes - Search
Page last modified on 2006-10-05 14:32 CEST