Search:   Help



LyX documentation


Shared groups


LyX /


Categories: LyX dependencies
<< | Page list | >>

Package dependencies

The aim of this page is to list required dependencies and problems for packagers of LyX.


LyX 2.4.x series need Qt >= 5.4, but >=5.6 for full usability. Qt 6 is also supported, we know about usability problem on MacOS platform though.

LyX 2.3.x series need Qt >= 4.8, widely tested with 4.8. For Qt 5 we suggest Qt 5.6 (widely tested).

LyX 2.2.x series need Qt >= 4.5, suggested is 4.8. Qt 5.x support is still experimental (for windows we suggest at highest 4.8.4).

LyX 2.1.x series need Qt >= 4.5, tested with 4.8. Qt 5.x support is still experimental.

LyX 2.0.x series need Qt >= 4.2, widely tested with 4.6/7/8. Be prepared that although is LyX compilable with older Qt's it also unstable with them.

LyX 1.6.x series need Qt >= 4.2, 4.5 is optimal (all features enabled).

LyX 1.5.x series need Qt >= 4.1


Avoid Ghostscript 8.70.


For better working of instant preview dvipng package should be installed.

LaTeX world

Some nonstandard packages needed for proper rendering of manuals: - xypic (texlive-pictures), mhchem (texlive-science) package needs to be found for manuals to work


Category: LyX dependencies

Edit - History - Print - Recent Changes - All Recent Changes - Search
Page last modified on 2024-01-18 19:59 UTC